System-Linux

Aller au contenu | Aller au menu | Aller à la recherche

Bloquer la mise à jour d'un paquet Centos ou Redhat

yum.jpeg

Yum Yum ! ! !

Voici comment exclure certains paquets non souhaités, lors de la mise à jour via la commande classique

yum update

Quand ceci vous arrive par exemple, pour x raisons :

Error: Package: php-mcrypt-5.3.5-1.el6.x86_32 (epel)                                                                          
           Requires: php-api = 20090728                                                                                       
           Installed: php-common-5.2.19-1.el6.art.x86_32 (@atomic)                                                            
               php-api = 20071222                                                                                             
 You could try using --skip-broken to work around the problem                                                                 
 You could try running: rpm -Va --nofiles --nodigest    

Il suffit d'éditer votre yum.conf et d'ajouter quelque chose comme :

exclude=php-mcrypt* 

Vous pouvez biensur exclure plusieurs paquets.

exclude=php-mcrypt* python* kernel*

Si vous ne souhaitez pas modifier votre yum.conf :

yum --exclude=nom-du-package* update
Par GanGan | le lundi, septembre 23 2013 15:00